読者です 読者をやめる 読者になる 読者になる

swfmillをコンパイルしたった

リポジトリに入っているswfmillが古かったので最新版をコンパイルした時のメモ
今回はバージョン0.3.2が最新ぽかったのでそれをインストールした。

必要なパッケージのインストール

今回インストールしたサーバでは以下のパッケージだけ足りなかった。
他の環境だとどうなのかは知らない。

Ubuntu
sudo aptitude install libxslt-dev
CentOS
sudo yum install libxml2-devel libxslt-devel

swfmillのインストール

まあ普通に取ってきてmakeするだけです。

wget http://swfmill.org/releases/swfmill-0.3.2.tar.gz
tar xf swfmill-0.3.2.tar.gz
cd swfmill-0.3.2
./configure --prefix=/usr/local/swfmill
make
sudo make install

おわり。